PCI DSS 3.2 Deadlines and Requirements – Security Boulevard


PCI DSS 3.2 Deadlines and Requirements
Security Boulevard
By now, many organizations have implemented PCI DSS v3.2 and though the previous version (v3.1) expired in October of 2016, some of the new requirements became effective February 1, 2018. Additional requirements are due to be effective in July 2018 ...

About PCI Blog 1242 Articles
PCI Blog is the most trusted PCI Compliance and IT Security blog on the web. Authored by industry experts within the payments and IT security industries, PCI Blog provides insight on the complex world behind modern compliance and security standards. As a wholly independent source of news within the payments industry, PCI Blog focuses on the ever-changing responsibilities of merchants who accept credit cards. PCI Blog also provides reviews on PCI compliance tools and enterprise security solutions to offer a fair, independent critique of product offerings within the payments industry.